SeaMonkey Internet Suite

Inoffizielle Neuigkeiten in deutscher Sprache

SeaMonkey 2.49.1 (ESR) ist erschienen, hier gibt es ergänzende Release-Notes

4 Kommentare

Blogpost Version 2017-11-08 (Sprachpaket-Version)

releasesBlogpost in englischer SpracheWir haben eine neues Release: SeaMonkey 2.49.1(ESR)

Im Folgenden ergänzende Release-Notes

Für den Abruf der folgenden Bugzilla-Abfragen wird ein Bugzilla-Account (ohne besondere Privilegien) benötigt. Alle Bugzilla-Abfragen rein auf der Basis von Versions– und Target-Milestone-Angaben, nicht systematisch überprüft! Aufgrund der uneinheitlich gehandhabten Verwendung von Target-Milestone-Angaben sind Ungenauigkeiten unvermeidlich

Die wichtigsten Neuerungen (Features)

Die Wiki-Seite dazu hat keine Einträge, welche der Firefox52 – Änderungen auch SeaMonkey 2.49.1 betreffen kann ich nicht sagen.

Hier eine Liste mit SeaMonkey 2.49.1-spezifischen RFE-Fixes.

 

Offensichtliche neue Features:

  • ?

Entfernte Features:

  • ?

Bugfixes

  • Fehler, die seit dem Erscheinen von SeaMonkey 2.48 für SeaMonkey 2.49.1 beseitigt wurden.
  • Fehler, die in Thunderbird und Firefox seit SeaMonkey 2.48 und deshalb wohl auch in SeaMonkey 2.49 nicht auftreten.
  • Es ist zu berücksichtigen, dass weder alle Fehler in Firefox oder  Thunderbird auch in SeaMonkey auftreten müssen noch absolut sicher ist, dass es jeder Thunderbird– und Firefox-Bugfix auch in den SeaMonkey-Code schafft.

Bekannte Probleme:

Siehe ofizielle Release Notes und diese Suchanfrage.

Mögliche neue Fehler („Regressions„)

  • Mögliche neue Fehler in SeaMonkey 2.49.1 — nur die mit Status New oder Assigned wurden auch schon als tatsächliche Bugs bestätigt.
  • Mögliche neue Fehler, die durch Regressions bei Firefox oder bei Thunderbird möglicher Weise auch SeaMonkey 2.49.1 betreffen (das sind sehr viele, Abfrage müsste gelegentlich überprüft und so modifiziert werden, dass sie ein realistischeres Bild der Situation gibt).

Workarounds zu neuen Fehlern finden sich eventuell im Wiki.

Mögliche alte und neue Fehler

Das ist eine schrecklich lange Liste, in der beispielsweise nicht berücksichtigt ist, dass nicht alle Thunderbird– und Firefox-Bugs auch für SeaMonkey relevant sein müssen und außerdem den falschen Eindruck erweckt, Produkte von Mozilla seien völlig unbrauchbar.

Eine zutreffendere Interpretation kommt zum Schluss:

  • Die vielen Bugs mit Status UNCONFIRMED müssen dringend durchforstet werden, da sind sicher sehr viele bei, die sich zwischenzeitlich erledigt haben, nur auf dem System des Reporters auftraten oder schlicht Falschmeldungen waren; jedenfalls ist das meine Erfahrung bei der systematischen Untersuchung der SeaMonkey-Bugs aus der Liste.
  • Wie jede Software enthält auch Mozilla-Software Fehler, die systematisch untersucht und behoben werden müssen, um die Produkte kontinuierlich zu verbessern.

Mögliche und bekannte Fehler

upsetrobotAchtung: Im (Mail- oder HTML)-Composer führt ‚Rechtsklick  →  Languages →  Download more dictionareis …‚ auf diese Seite „Dictionaries & Language Packs“ mit Link auf ein Deutsches Sprachpaket für SeaMonkey x.yz. Dieses Sprachpaket darf keinesfalls für ein andere Version installiert werden — vermutlich wird SeaMonkey die Installation auch verweigern. Wer den Add-On-Konverter benutzt könnte aber dazu verführt werden, das Sprachpaket anzupassen und dann zu installieren. Ein Sprachpaket mit falscher Version kann aber zu schwerwiegenden Fehlfunktionen bis hin zur Unbenutzbarkeit des User-Profils führen.

Sonstiges:

Es wird SSE2-taugliche Hardware für SeaMonkey 2.49. benötigt — zumindest für Windows

Chatzilla & DOM Inspector

Wurden für  SeaMonkey 2.491 aus dem Installer wegen Problemen mit der Lokalisierungs-Infrastruktur entfernt. Details: Bug 1231349 L10n repacks broken on with SM 2.42 and newer.

Bei Bedarf können diese Add-Ons vom AMO herunter geladen werden:

Catzilla vom AMO funktioniert problemlos, auch das deutsche Sprachpaket lässt sich problemlos zu  SM 2.46 installieren und funktioniert. Mit einem bestehenden Nutzerprofil mag der User gar nicht bemerken, dass SeaMonkey 2.49.1 ohne CZ ausgeliefert wurde, weil die alte Version von CZ einfach weiter arbeitet.

DOM Inspector 2.0.16.1-signed ist lt. AMO nur bis SeaMonkey 2.39 kompatibel. Download Link in den offiziellen Release Notes.

Rechtschreibprüfung

Zusätzlich zu den bekannten Wörterbüchern für die Rechtschreibprüfung, die in aller Regel zumindest nach Konvertierung installiert werden können, ist auch die Verwendung von Thunderbird- und Firefox- Wörterbüchern möglich.

Add-On-Konvertierung für SeaMonkey

Ein sehr leistungsfähiger Konvertierer macht eine große Anzahl von Firefox- und Thunderbird-Addons für SeaMonkey nutzbar. Über ein Addon kann diese Konvertierung jetzt mit einem einzigen Mausklick aus dem AMO heraus erfolgen, beispielsweise auch für Wörterbücher.

Achtung: Für Sprachpakete ist keine Konvertierung möglich, obwohl das vom AMO Browsing for SeaMonkey-Addon (derzeit noch) vorgeschlagen wird (siehe auch oben!).


Also dann, und vielen Dank an alle, die Release 2.49.1 ermöglicht haben, und viel Spaß damit!

Rainer

 

Advertisements

Autor: rrbd

Freelancer, Engineer, Camper, Canoeist

4 Kommentare zu “SeaMonkey 2.49.1 (ESR) ist erschienen, hier gibt es ergänzende Release-Notes

  1. Dieses Mal hat es auch schnell mit der Erwähnung des neuen Releases auf der deutschen SeaMonkey-Seite geklappt ☺.

    Gefällt mir

  2. Guten Abend!

    Läuft!

    Zu ChatZilla:

    Version 0.9.9.3 mit deutschem Sprachpaket ist hier vorhanden, wobei das Sprachpaket nach dem Neustart von SeaMonkey automatisch nachinstalliert wurde.

    Zum DOMI:

    Version 2.0.27.0 läuft mit SeaMonkey 2.49.1. Die alte Version funktionierte tatsächlich schon lange nicht mehr richtig oder eben gar nicht.

    Irgendwo wurde mal behauptet, daß Lightning nicht funktionieren soll. Merkwürdig, gerade damit hatte ich bis heute wohl die wenigsten Probleme und natürlich funktioniert das Add-on einwandfrei seit meiner ersten Testversion von SeaMonkey 2.49.

    Der Add-on-Konverter gefällt mir übrigens von Tag zu Tag besser! Derzeitig habe ich 13 konvertierte Add-ons und alle scheinen richtig zu funktionieren. Allerdings brauche ich nicht alle Funktionen meiner Add-ons, bei insgesamt 68 Stück kann ich aber auch nicht alles testen! 😉

    Und ja, falsche Sprachpakete können zu unabsehbaren Problemen führen! Mir ist das leider schon öfter passiert, das kann ich also aus persönlicher Erfahrung nur bestätigen… 😦

    Gefällt 1 Person

  3. DOMi 2.0.17.1 gibt es hier:

    https://archive.mozilla.org/pub/seamonkey/releases/2.49.1/distributed/

    Steht auch in den Release Notes.
    https://www.seamonkey-project.org/releases/seamonkey2.49.1/

    Läucft auch noch mit den allerersten 2.54 Alphas. Dann hat Mozilla den Source Tree demontiert. Wenn ich mal zeit finde schaue ich es mir an aber im Moment ziemlich witzlos mit den ganzen Änderungen im Addon Bereich. Wenn Sie so schnell mit neuen Apis für Web Extensions wären aber einreißen geht ja schneller als was Neues bauen…

    FRG

    Gefällt mir

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s