SeaMonkey Internet Suite

Inoffizielle Neuigkeiten in deutscher Sprache

Neue inoffizielle lokalisierte SeaMonkey 2.48- und 2.49-Builds verfügbar

23 Comments

Blogpost in englischer SpracheNewNightlyAdrian Kalla hat mal wieder seine Build-Maschine angeworfen, es gibt neue inoffizielle SeaMonkey-Builds (Beta und Release) sowie Sprachpakete für Linux, Mac und Windows. Mit dabei sind Lightning-Kalender und weiteres “Zubehör”.

Download-Verzeichnisse:

[DIR] latest-comm-beta-linux32/ 2017-01-30 08:28
[DIR] latest-comm-beta-linux64/ 2017-01-30 06:13
[DIR] latest-comm-beta-windows64/ 2017-01-30 05:22
[DIR] latest-comm-release-linux32/ 2017-01-30 03:42
[DIR] latest-comm-release-linux64/ 2017-01-30 01:07
[DIR] latest-comm-release-windows32/ 2017-01-29 22:44
[DIR] latest-comm-release-windows64/ 2017-01-29 17:57

 

Bitte diese inoffizielle Builds eifrig, aber vorsichtig testen! Meistens funktionieren auch diese Builds trotz ihres experimentellen Entwicklungsstadiums sehr gut, aber ab und an kann auch mal einer dazwischen sein, das einem das User-Profil zerkloppt (mir letztmals vor dem Wochenende passiert), also lieber immer erst mal ein Backup anlegen!

Es wäre interessant zu wissen, ob auch diese Trunk-Builds von der Bug-Epidemie betroffen sind.

Benutzung für Testzwecke auf eigene Gefahr und ohne jede Gewährleistung!

Advertisements

Author: rrbd

Freelancer, Engineer, Camper, Canoeist

23 thoughts on “Neue inoffizielle lokalisierte SeaMonkey 2.48- und 2.49-Builds verfügbar

  1. Diese SeaMonkey 2.48 hat zumindest in der Windows DE Version einen Fehler bei der Anmeldung an Webseiten mit Basic Authentication. Es wird nicht nach Benutzer/Passwort gefragt. (Bei 2.47 funktionierte es noch)

    Liked by 1 person

  2. In der 2.48 erscheint der Anmeldedialog (Benutzername/Passwort) nicht mehr (z.B. https://members.spamcop.net/).
    In 2.47 funktioniert das noch einwandfrei.

    Liked by 1 person

    • @Axel:
      Kein Problem mit Server-Installation of unofficial (by FRG) en-US SeaMonkey 2.51a1 (NT 6.1; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0 Build 20170130073756 (Default Classic Theme) on German WIN7 64bit. Bei Aufruf der Seite über den Link oben (in neuem TAB) erscheint der 2-Zeilige Passwortdialog.
      Probierst Du mal “Safe Mode (ohne Addons) und neues User-Profil aus?
      Wenn das keine Klarheit bringt teste ich mal Deine 2.48-Version.

      Like

      • @rrbd:
        Siehe 10:34 UTC: Im Safe-Mode bleibt das Problem, in einem neuen Profil geht es.
        User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0 SeaMonkey/2.48
        Build-Identifikator: 20170129191635
        Win7 64 Bit (Default Classic Theme)

        Liked by 1 person

  3. Danke für die Rückmeldungen, ich gehe den angesprochenen Problemen kurzfristig nach und hake hier noch mal nach, wenn ich weitere Informationen brauche.

    Like

  4. Kann ich zumindest in der Win32 Version nicht nachvollziehen. Mit 2.48 und 2.49 gab es einige Änderungen am Javascript Interpreter inkl. Wegfall von alter Syntax. Das hat einige Add-Ons inkompatibel gemacht. Ich würde es mal mit einem neuen Testprofil versuchen.

    Liked by 1 person

  5. Das Problem bleibt im abgesicherten Modus, also ohne Add-Ons, bestehen.
    In einem neuen Testprofil ist das Problem weg.
    Das kann aber nicht die Lösung sein …

    Liked by 1 person

  6. Spannend. Kannst du die englische Version probieren. Einfach drüber installieren. Nach dem Test kann dann die deutsche Version wieder drauf. Wird in der Fehler Konsole etwas ausgegeben?

    Liked by 1 person

    • @Frank-Reiner:
      Das Problem besteht auch mit der englischen Version.
      In der Fehler-Konsole wird einiges an Javascript-Fehlern ausgegeben:

      Zeitstempel: 01.02.2017 11:12:02
      Fehler: TypeError: win.gBrowser is undefined
      Quelldatei: resource://gre/components/nsLoginManagerPrompter.js
      Zeile: 1373

      Zeitstempel: 01.02.2017 11:12:02
      Fehler: nsPrompter: Delegation to password manager failed: [Exception… “[JavaScript Error: “win.gBrowser is undefined” {file: “resource://gre/components/nsLoginManagerPrompter.js” line: 1373}]'[JavaScript Error: “win.gBrowser is undefined” {file: “resource://gre/components/nsLoginManagerPrompter.js” line: 1373}]’ when calling method: [nsIPromptFactory::getPrompt]” nsresult: “0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)” location: “JS frame :: resource://gre/components/nsPrompter.js :: Prompter.prototype.getPrompt :: line 42” data: yes]
      Quelldatei: resource://gre/components/nsPrompter.js
      Zeile: 44

      Zeitstempel: 01.02.2017 11:12:02
      Fehler: uncaught exception: 2147500033

      Zeitstempel: 01.02.2017 11:12:02
      Fehler: TypeError: checkValue is undefined
      Quelldatei: resource://gre/components/nsPrompter.js
      Zeile: 741

      Danach folgen eine Menge Warnungen.

      Liked by 1 person

  7. Ich hatte nach dem Problem mit der 2.48 (Win32 DE unter Win10) die 2.47 vom 22.12.2016 installiert – der Fehler war danach wieder verschwunden.

    Als ich dann den Kommentar las, dass es nicht nachvollziebar ist, wollte ich den Fehler einkreisen und hab das automatische Update
    auf die 2.48 durchgeführt (wie vorher) – mit dem Ergebnis das es jetzt funktioniert!
    Ich habe mein Profil nicht verändert und auch keine Plugins installiert/deinstalliert.

    Die vorherige Installation wurde allerdings mit der 2.47 ausgeführt, die ich am 9.12. heruntergeladen hatte – vielleicht macht das den
    Unterschied? (Die seamonkey-2.47.de.win32.installer.exe unterscheiden sich in der Größe)

    Liked by 1 person

  8. Ich habe jetzt bei einem zweiten Win10 (64Bit) Rechner von der offiziellen 2.46 (32Bit) mit der seamonkey-2.47.de.win32.installer.exe (die ich am 9.12.2016 heruntergeladen hatte) auf die 2.47 geupdated und anschliessend per automatischem Update auf die 2.48 aktualisiert.
    Der Fehler tritt nicht auf – es liegt also nicht an dieser Vorgängerversion.

    Liked by 1 person

  9. >> In der Fehler-Konsole wird einiges an Javascript-Fehlern ausgegeben:

    Das klingt alles nach einem angeschlagenen Profil und eigentlich alles Gecko Code. Mit 2.48 hat Mozilla die logins.json um die Ausnahmen bereinigt und in die permissions DB überführt. Benenne logins.json doch mal testweise um. Möglicherweise wurde die Datei beim Upgrade beschädigt. Setzt du irgendwelche Passwort Helfer Addons ein? Ich weiß sollen mit Safe Mode inaktiv sein aber das es in einem neuen Profil funktioniert muß irgendwas an deinem kaputt sein.

    Liked by 1 person

  10. Ein Umbennen der logins.json brachte keinen Unterschied (außer daß die Passwörter weg waren).

    Und nein, ich setze keine Passwort Helfer Addons ein.

    Like

  11. Ich habe jetzt im Moment das Update 2.47 – ->2.48 auf meinem Heim-PC über die interne Updatefunktion gemacht (also gänzlich anderes Profil) und es tritt exakt der gleiche Fehler auf wie am anderen PC.

    Liked by 1 person

  12. Ich habe bei 2 weiteren PC von 2.47 auf 2.48 und von 2.46 auf 2.48 aktualisiert, ohne das Problem festzustellen.

    Aber: ich habe inzwischen zwei PC bei denen ich mit 2.47 und 2.48 keine Mails verfassen kann.
    Sobald ich auf “Verfassen” klicke stürzt Seamonkey mit Crashreport ab. Eine leeres neue Mail ist kurzzeitig sichtbar.
    MozCrashReason: ElementAt(aIndex = 2, aLength = 2)
    Nach downgrade auf 2.46 funktioniert es wieder, nach upgrade auf 2.47 oder 2.48 ist der Absturz wieder da.
    Mail als HTML oder als Text verfassen ändert nichts.

    Liked by 1 person

  13. Axel,

    blöder Fehler. Ich kann es hier auf x Installationen nicht nachstellen. 2.48 habe ich auch lange benutzt und nie Probleme gehabt. Am besten einen Bug report aufmachen Ist per blog etwas schwierig. Kannst du die permissions.sqlite vielleicht mal umbenennen. da hat sich vielleicht Schrott angesammelt.

    Klaus,

    der Fehler wurde öfters gemeldet. Thunderbird kämpft mit dem auch. Allerdings nicht gleich beim Verfassen ein Mail. Kannst du es mal im Safe Mode probieren.

    Liked by 1 person

    • Ich habe wegen des Crash beim Mail-Verfassens jetzt folgendes probiert:
      – aufruf mittels -safe-mode
      – im Kompatibilitätsmode XP SP3, als Admin, niedrige Auflösung, keine Textscalierung
      – deinstallieren, löschen der Seamonkey-Ordner in appdata/local, appdata/roaming und programme x86, anschliessender Neuinstallation der 2.48. und Anlegen eines pop Mailaccounts ohne gültigen Server

      In allen Fällen beendet sich Seamonkey sobald ich mail Verfassen anklicke und das Fenster kurz zu sehen ist.
      Es muß also an irgendetwas liegen das auf den beiden Rechnern istalliert ist… aber was?
      In der Ereignisanzeige findet sich nichts.
      Irgendwelche Ideen, was ich testen könnte?

      Liked by 1 person

  14. Ein Umbennen der permissions.sqlite hat nichts gebracht.

    Habe dann noch den Weg von Klaas versucht (nochmal 2.47 installiert nochmal upgedated) hat auch nichts gebracht.

    Was die Profile auf beiden meiner PCs gemeinsam haben ist, daß sie sehr alt sind.

    Liked by 1 person

  15. Klingt eigentlich wie “Bug 1300539 – Authentication not triggered on nightlies Seamonkey only ” der fixed ist.

    Liked by 1 person

    • Ich habe vielleicht eine Information zu dem Anmeldeproblem:

      Auf meinem Arbeitsplatzsystem tritt es manchmal auf, und manchmal nicht, ohne irgendetwas zu installieren.

      Ich habe festgestellt, dass der Anmeldedialog nicht erscheint, wenn beim Öffnen eines Browserfensters ein
      Seamonkey-Mail Fenster offen war, und noch offen ist.

      a1. Browserfenster starten -> Anmeldung funktioniert

      b1. Seamonkey Mail starten
      b2. Browserfenster starten -> Anmeldedialog erscheint nicht
      b3. Seamonkey Mail beenden
      b4. Browserfenster kann sich danach anmelden

      c1. Browserfenster1 starten -> Anmeldung funktioniert
      c2. Seamonkey Mail Fenster öffnen
      c3. Browserfenster1 kann sich weiterhin anmelden!
      c4. vom Browserfenster1 ein neues Browserfenster2 starten
      -> Browserfenster1 kann sich immer noch anmelden
      -> Browserfenster2 kann sich nicht anmelden
      c5. Seamonkey Mail beenden
      -> Beide Browserfenster können sich anmelden

      Vielleicht hilft es weiter….

      Liked by 1 person

  16. Ja aber Bug 1300539 ist sicher in 2.48. Den hatte ich ja selbst gefixed. Da waren die Fehlermeldungen auch anders. Wird irgendeine alte Einstellung im Profil sein. Die Frage ist nur welche…

    Liked by 1 person

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s