SeaMonkey Internet Suite

Inoffizielle Neuigkeiten in deutscher Sprache

Nightly-User-Builds (Windows): Erste Erfahrungen

2 Kommentare

Gift!Nur gut, dass wir nun wieder nach langer Zeit  erste Builds haben, zumindest meine Erfahrungen zeigen dringenden Bugfixbedarf – oder vielleicht müssen auch nur die Build-Parameter angepasst werden. Oder ich bin ein Pechvogel, bei anderen ist alles paletti!?!

Ich habe bisher 2 Builds getestet:

  • EN-US SeaMonkey 2.38a1 build by Philip Chee, Gecko/20100101 , Build 20150601233926 (Classic Theme) on German WIN7 64bit

  • EN-US SeaMonkey 2.38a1 build by Ruediger Lahl, Gecko/20100101, Build 20150531140409 ( Classic Theme) on German WIN7 64bit

In Details gibt es Unterschiede, aber im Wesentlichen gleichen sich die Ergebnisse:

  1. Mit meinem Test-Userprofil funktionierten beide ganz passabel
  2. Mit meinem Standard-Userprofil sind beide unbenutzbar. Die Benutzeroberfläche ist völlig zerschossen, Bookmarks fehlen, alle E-Mail-Accounts sind abhanden gekommen

Zumindest eine wesentliche Ursache scheint mir zu sein, dass aus unerfindlichen Gründen anscheinend die Information über den Profilordner verloren geht – warum nicht auch bei dem zig Jahre alten Default-Profil , das ich ausschließlich für Testzwecke verwende (und auch nicht bei anderen Testprofilen) ist schwer zu verstehen. Grund für meine Vermutung: In den Erweiterten Einstellungen ist der Ordner-Eintrag für den Cache-Pfad leer, SeaMonkey weiß nicht, wo der Cache sein soll. Vermutlich fehlen auch andere Ordnerinformationen zum Profil.

Es wäre spannend zu wissen, ob andere User diese Probleme bestätigen können.

Oder aber das alles ist Blödsinn, weil es tatsächlich nur mein Normal-Profil betrifft. Ich habe noch andere existierende Profile getestet, da war alles in Ordnung.

Hier noch ein paar Screenshots von Problemen, die so nur in meinem gewohnten Standard-Profil sichtbar sind:


Immerhin verursachten die Builds anscheinend keine bleibenden Schäden im Profil, im „normalen“ 2.33.1 ist wieder alles in Butter, wenn ich ihn aufrufe.

Ich mache mal ’nen Bug dafür auf – morgen!

Weitere Erfahrungen? Wer selbst hier einen etwas ausführlicheren Bericht hinterlassen möchte, bekommt Editorenrechte von mir.

Nachträge

2015-06-03 17:50 UTC

Ein erster vager Verdacht, das Profil-Problem könne damit zusammenhängen, dass das problematische das einzige ist, dessen Ordnername mit einer Ziffer beginnt, hat sich nicht bestätigt; Eine Identische Kopie des Profils, nur mit geändertem Ordnernamen ohne Ziffer am Anfang, funktionierte nach Eintrag in profiles.ini mit 2.3.3.1, einwandfrei, zeigte aber mit SeaMonkey 2.38a1 wieder die oben aufgeführten Probleme. Also weiter suchen!

Advertisements

Autor: rrbd

Freelancer, Engineer, Camper, Canoeist

2 Kommentare zu “Nightly-User-Builds (Windows): Erste Erfahrungen

  1. Nachtrag 2015-06-05 07:00 UTC

    Ich habe Bug 1171816 Input lines hight much too small, spinboxes missing, other UI problems für diese Probleme geöffnet.

    Weitere Untersuchungen ergaben inzwischen, dass die Probleme möglicherweise durch ein fatales Zusammenwirken mit einem Add-on entstehen, jedenfalls verschwinden die Probleme im „SaveMode“ mit inaktiven Add-ons

    Gefällt mir

  2. Nachtrag 2015-06-05 15:15 UTC

    BugHuntingSession1εὕρηκα, ich hab’s gefunden! Das Problem tritt auf, wenn man ein (veraltetes 2.33(?)) Sprachpaket benutzt. Und wie mir scheint, benutzt SeaMonkey auch in der EN-US-Grundversion ein vorhandenes (und im Add-On-Manager aktiviertes) EN-US-Sprachpaket. Aktive unbenutzte Sprachpakete richten keinen Schaden an, aber sowie ich eines davon aktiviere (Ich habe Deutsches und Französisches Language-Pack getestet) geht der Zirkus los!

    Mit abgeschalteten Sprachpaketen funktioniert mein EN-US SeaMonkey 2.37a2 build by User Herzel, Gecko/20100101 , Build 20150522012631 (Classic Theme) on German WIN7 64bit bisher übrigens tadellos (soweit man das nach ½ Stunde Test sagen kann), auch diesen Kommentar verfasse ich gerade mit dem Aurora. Auch die verschiedenen erwähnten Trunk-Versionen zeigten in Schnelltests keine Auffälligkeiten.

    Ob das eine vermeidbare Verwundbarkeit (bezüglich veralteter Sprachpakete(?)) ist oder ein grundsätzliches Sprachpaketsproblem bei Aurora und später oder noch etwas anderes muss ein Fachmann in Bug 1171816 entscheiden.

     

    Gefällt mir

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s